aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-29 12:06:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commitd1eda517f3db8711c4f4fbff5c5ae31233813693 (patch)
tree115b4805be00c15214c3f7638a525dfea8cf11c7
parent83262c971e77552978e3482421256096d8878d2b (diff)
downloadguix-d1eda517f3db8711c4f4fbff5c5ae31233813693.tar
guix-d1eda517f3db8711c4f4fbff5c5ae31233813693.tar.gz
gnu: Add python-param.
* gnu/packages/python-xyz.scm (python-param): New variable. Change-Id: Idad928488d7c306c969b4484a3cd22661c41d488
-rw-r--r--gnu/packages/python-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e93020f6a7..ed48c0ea62 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31966,6 +31966,48 @@ heterogeneous and multi-platform clusters (including clusters running other
applications with variable CPU loads).")
(license license:bsd-3)))
+(define-public python-param
+ (package
+ (name "python-param")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "param" version))
+ (sha256
+ (base32 "07z7az7xg8pzjrmaf928is7n6siw9v9nxfmf0a5vgqj7nl40pcx7"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-cloudpickle
+ python-coverage
+ python-hatchling
+ python-hatch-vcs
+ python-ipython
+ python-jsonschema
+ python-nbval
+ python-nest-asyncio
+ python-numpy
+ python-odfpy
+ python-openpyxl
+ python-pandas
+ python-pyarrow
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-xdist
+ python-tables
+ python-xlrd))
+ (home-page "https://param.holoviz.org/")
+ (synopsis
+ "Make your Python code clearer and more reliable by declaring Parameters")
+ (description
+ "Param is a library for handling all the user-modifiable parameters,
+arguments, and attributes that control your code. It provides automatic,
+robust error-checking while dramatically reducing boilerplate code, letting
+you focus on what you want your code to do rather than on checking for all the
+possible ways users could supply inappropriate values to a function or
+class.")
+ (license license:bsd-3)))
+
(define-public python-djitellopy
(package
(name "python-djitellopy")