aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-03 14:44:40 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-03 14:58:49 +0200
commitcf53ecf514301d3ffdfc33dea057b057ffb132d6 (patch)
tree2d2dfb8ca9a950488134b288c723cca04adfd637
parentadb5f46940aec2a58446c647487998beaa31f412 (diff)
downloadguix-cf53ecf514301d3ffdfc33dea057b057ffb132d6.tar
guix-cf53ecf514301d3ffdfc33dea057b057ffb132d6.tar.gz
gnu: bigloo: Add dependencies on Avahi and libphidget.
* gnu/packages/scheme.scm (bigloo): Add Avahi and libphidget as inputs, and pkg-config as a native input.
-rw-r--r--gnu/packages/scheme.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 59e1da22ac..4b42f8c53c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -28,6 +28,9 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages patchelf)
#:use-module (gnu packages which)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages libphidget)
#:use-module (ice-9 match))
(define-public mit-scheme
@@ -161,7 +164,13 @@ development cycle.")
%standard-phases)))))
(inputs
`(("emacs" ,emacs)
- ("patch/shebangs" ,(search-patch "bigloo-gc-shebangs.patch"))))
+ ("patch/shebangs" ,(search-patch "bigloo-gc-shebangs.patch"))
+
+ ;; Optional APIs for which Bigloo has bindings.
+ ("avahi" ,avahi)
+ ("libphidget" ,libphidget)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(propagated-inputs
`(("gmp" ,gmp))) ; bigloo.h refers to gmp.h
(home-page "http://www-sop.inria.fr/indes/fp/Bigloo/")