aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 19:56:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 19:56:44 +0100
commitcec2654f9757e0a92a552018d4c72fdb630625bb (patch)
tree951448ce2d94b9086a4d85b5447deb2678e4ae02
parent342411a327041cee1e97a8152a1d72e0e127df9a (diff)
downloadguix-cec2654f9757e0a92a552018d4c72fdb630625bb.tar
guix-cec2654f9757e0a92a552018d4c72fdb630625bb.tar.gz
gnu: go-github-com-gatherstars-com-jwz: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-gatherstars-com-jwz): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I9c5c08dc04ee88cd60c24d8efced194acacc9f7d
-rw-r--r--gnu/packages/golang-web.scm32
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 31 insertions, 29 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 38357010e1..276a8a9ad2 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -10,11 +10,12 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
-;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022 Adam Kandur <kefironpremise@gmail.com>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -756,6 +757,35 @@ API and doesn't use reflection. It relies on small interfaces to
decode/encode structures and slices.")
(license license:expat)))
+(define-public go-github-com-gatherstars-com-jwz
+ (package
+ (name "go-github-com-gatherstars-com-jwz")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gatherstars-com/jwz")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1d66axc3504wqpb4axlm8m9jq8rmwndxb4asbqwryymj3yh60cla"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/gatherstars-com/jwz"))
+ (propagated-inputs
+ (list go-github-com-rivo-tview
+ go-github-com-jhillyerd-enmime
+ go-github-com-gdamore-tcell-v2))
+ (home-page "https://github.com/gatherstars-com/jwz")
+ (synopsis "Email threading algorithm in Golang")
+ (description
+ "The jwz package provides an implementation of the email threading
+algorithm originally designed for use in
+@url{https://www.jwz.org/doc/threading.html,Netscape Mail 2.0 and 3.0} for
+Golang.")
+ (license license:asl2.0)))
+
;; TODO: This repository has been archived by the owner on Aug 30, 2023. It is
;; now read-only. The raven-go SDK is no longer maintained and was superseded
;; by the sentry-go
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cd97d891dd..e68b0ba07d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8734,34 +8734,6 @@ text-only mail clients to display them.")
library geared towards parsing MIME encoded emails.")
(license license:expat)))
-(define-public go-github-com-gatherstars-com-jwz
- (package
- (name "go-github-com-gatherstars-com-jwz")
- (version "1.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gatherstars-com/jwz")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1d66axc3504wqpb4axlm8m9jq8rmwndxb4asbqwryymj3yh60cla"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/gatherstars-com/jwz"))
- (propagated-inputs (list go-github-com-rivo-tview
- go-github-com-jhillyerd-enmime
- go-github-com-gdamore-tcell-v2))
- (home-page "https://github.com/gatherstars-com/jwz")
- (synopsis "Email threading algorithm in Golang")
- (description
- "The jwz package provides an implementation of the email threading
-algorithm originally designed for use in
-@url{https://www.jwz.org/doc/threading.html,Netscape Mail 2.0 and 3.0} for
-Golang.")
- (license license:asl2.0)))
-
(define-public go-github-com-creack-pty
(package
(name "go-github-com-creack-pty")