aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-30 09:58:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-30 09:58:58 +0300
commitcb4f96a3db5ab28dbabd23905e74703e6871f7a1 (patch)
tree73273772183cf9e35fd1c54d98206823a10e0768
parentf653a07bb893b028fdbfa2f46f486fcda6731d70 (diff)
downloadguix-cb4f96a3db5ab28dbabd23905e74703e6871f7a1.tar
guix-cb4f96a3db5ab28dbabd23905e74703e6871f7a1.tar.gz
gnu: qemu: Skip another test on riscv64-linux.
* gnu/packages/virtualization.scm (qemu)[arguments]: Adjust the 'disable-some-tests phase to skip another test. Change-Id: Ia781e0514898f95042064416d059a7ff9bc75c52
-rw-r--r--gnu/packages/virtualization.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4a3cb9be20..59137eb2d4 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -358,7 +358,10 @@
;; No 'PCI' bus found for device 'virtio-scsi-pci'
(delete-file "tests/qemu-iotests/127")
- (delete-file "tests/qemu-iotests/267"))))
+ (delete-file "tests/qemu-iotests/267")
+
+ ;; This test takes too long.
+ (delete-file "tests/qemu-iotests/tests/iothreads-stream"))))
'())
(add-after 'patch-source-shebangs 'patch-embedded-shebangs
(lambda* (#:key native-inputs inputs #:allow-other-keys)