aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:57:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:58:36 +0100
commitca88519403621879c59211eb4b25c76a2a6f0fc0 (patch)
treeace57aaa009e7ec507058b099927bb94a8ed3055
parent7fe99a5fafcab6161bcc497dfd6c8e5c97b39271 (diff)
downloadguix-ca88519403621879c59211eb4b25c76a2a6f0fc0.tar
guix-ca88519403621879c59211eb4b25c76a2a6f0fc0.tar.gz
gnu: go-github-com-stretchr-objx: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-stretchr-objx): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I2ab70003a3d85812a6905a60c84af88e0df1e133
-rw-r--r--gnu/packages/golang-xyz.scm38
-rw-r--r--gnu/packages/golang.scm38
2 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5638eea5fd..c0ead7d512 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5260,6 +5260,44 @@ well as a program to generate applications and command files.")
(home-page "https://github.com/stathat/go")
(license license:expat))))
+(define-public go-github-com-stretchr-objx
+ (package
+ (name "go-github-com-stretchr-objx")
+ (version "0.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/objx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jcxpfgfpk82lryjkhbd5dy7xzx08d7b9dvbx4bpkmjvn6p339jl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/stretchr/objx"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
+ (native-inputs
+ ;; go-spew and go-difflib are to cover testify-bootstrap and not required
+ ;; for odjx itself.
+ (list go-github-com-davecgh-go-spew
+ go-github-com-pmezard-go-difflib
+ go-github-com-stretchr-testify-bootstrap))
+ (home-page "https://github.com/stretchr/objx")
+ (synopsis "Go package for dealing with maps, slices, JSON and other data")
+ (description
+ "This package provides a Go library for dealing with maps,
+slices, JSON and other data.")
+ (license license:expat)))
+
(define-public go-github-com-syndtr-goleveldb
(package
(name "go-github-com-syndtr-goleveldb")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 739376302d..c776f78609 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3193,44 +3193,6 @@ developed by the Go team. It provides IDE features to any LSP-compatible
editor.")
(license license:bsd-3)))
-(define-public go-github-com-stretchr-objx
- (package
- (name "go-github-com-stretchr-objx")
- (version "0.5.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/objx")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jcxpfgfpk82lryjkhbd5dy7xzx08d7b9dvbx4bpkmjvn6p339jl"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/stretchr/objx"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (native-inputs
- ;; go-spew and go-difflib are to cover testify-bootstrap and not required
- ;; for odjx itself.
- (list go-github-com-davecgh-go-spew
- go-github-com-pmezard-go-difflib
- go-github-com-stretchr-testify-bootstrap))
- (home-page "https://github.com/stretchr/objx")
- (synopsis "Go package for dealing with maps, slices, JSON and other data")
- (description "This package provides a Go library for dealing with maps,
-slices, JSON and other data.")
- (license license:expat)))
-
(define-public go-github-com-tevino-abool
(let ((commit
"3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")