aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2024-09-21 23:47:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 10:08:28 +0100
commitc46b23421ec48bb488e082bc449b377f3bc40255 (patch)
treef70f35139a632c8f5814a75bf915c33695d065f6
parentae7fc060c0980e6276b0163ad76e2a125d1db9f3 (diff)
downloadguix-c46b23421ec48bb488e082bc449b377f3bc40255.tar
guix-c46b23421ec48bb488e082bc449b377f3bc40255.tar.gz
gnu: python-twine: Update to 5.1.1.
* gnu/packages/python-xyz.scm (python-twine): Update to 5.1.1. [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Disable failing tests. [native-inputs]: Add python-pretend, python-pytest, python-pytest-socket. [propagated-inputs]: Remove python-tqdm, python-packaging. Add python-imporlib-metadata, python-keyring, python-rfc3986, python-rich and python-urllib3. Reviewed-by: Steve George <steve@futurile.net> Change-Id: I55dbcd646dec60cfe8ec226aed0cf3f8c59e2eeb Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 503d8f510f..7b3a193856 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25726,25 +25726,37 @@ created by running @code{python setup.py develop}).")
(define-public python-twine
(package
(name "python-twine")
- (version "1.15.0")
+ (version "5.1.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "twine" version))
- (sha256
- (base32 "11rpd653zcgzkq3sgwkzs3mpxl3r5rij59745ni84ikv8smjmlm3"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "twine" version))
+ (sha256
+ (base32 "1nr24gd5gm22b0jzb5qmw4swh8bshixmqm0kv4s38ay0758q584s"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags ;; Disable failing tests.
+ #~(list "-k" (string-append
+ "not test_pkginfo_returns_no_metadata"
+ " and not test_fails_rst_no_content"))))
+ (native-inputs
+ (list python-pretend
+ python-pytest
+ python-pytest-socket))
(propagated-inputs
- (list python-tqdm
- python-packaging
+ (list python-importlib-metadata
+ python-keyring
python-pkginfo
python-readme-renderer
python-requests
- python-requests-toolbelt))
+ python-requests-toolbelt
+ python-rfc3986
+ python-rich
+ python-urllib3))
(home-page "https://github.com/pypa/twine")
(synopsis "Collection of utilities for interacting with PyPI")
(description
- "@code{twine} currently supports registering projects and uploading
+ "@code{twine} currently supports registering projects and uploading
distributions. It authenticates the user over HTTPS, allows them to pre-sign
their files and supports any packaging format (including wheels).")
(license license:asl2.0)))