aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-09-15 13:31:41 +0100
committerChristopher Baines <mail@cbaines.net>2019-09-21 17:27:22 +0100
commitc219104c7803cd31ab1cf4bef142a8fbf8ed5b7a (patch)
tree200ce3cb8d4716b8a3c296853a44ad3debe0b2ce
parent660dbe65641851aa99b810e4ae065a5f72dc37d0 (diff)
downloadguix-c219104c7803cd31ab1cf4bef142a8fbf8ed5b7a.tar
guix-c219104c7803cd31ab1cf4bef142a8fbf8ed5b7a.tar.gz
gnu: guile-email: Add phase to patch the module directory.
Otherwise the .go files appear within share, and Guile doesn't find them. With this patch they appear in lib within the output. One thing this means is that stack traces include the filenames. * gnu/packages/guile-xyz.scm (guile-email)[arguments]: Add 'patch-module-dir phase.
-rw-r--r--gnu/packages/guile-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d6967929be..9822cd59c6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -926,7 +926,16 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
(inputs
`(("guile" ,guile-2.2)))
(arguments
- '(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-module-dir
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^godir = ([[:graph:]]+)")
+ "godir = \
+$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
+ #t)))))
(home-page "https://guile-email.systemreboot.net")
(synopsis "Guile email parser")
(description "guile-email is a collection of email utilities implemented