aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:33:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:25 +0200
commitbf113089ce4cadf4dd127bcdee3490821bca4027 (patch)
tree71b1b05c598cf2c2f1e03c20d653ecbced45a457
parentfe7c83abd410b8c27ba6ad3088be8931a96e6243 (diff)
downloadguix-bf113089ce4cadf4dd127bcdee3490821bca4027.tar
guix-bf113089ce4cadf4dd127bcdee3490821bca4027.tar.gz
gnu: Add texlive-ebook.
* gnu/packages/tex.scm (texlive-ebook): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a542235e97..f543b1461b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11817,6 +11817,25 @@ are provided.")
mathematics.")
(license license:lppl1.3+)))
+(define-public texlive-ebook
+ (package
+ (name "texlive-ebook")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ebook/" "tex/latex/ebook/")
+ (base32
+ "1i9zixl8wiwmfrhrzwm2adgwm5kzqk5xaq5nq9bks9i2ayvmiij2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ebook")
+ (synopsis "Helps creating an ebook by providing an @code{ebook} class")
+ (description
+ "The package defines a command @code{\\ebook} that defines page layout,
+fonts, and font-sizes for documents to be rendered as PDF-ebooks on small
+ebook-readers.")
+ (license license:public-domain)))
+
(define-public texlive-ecc
(package
(name "texlive-ecc")