aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
commitbdb664f7b0df111b0ff5a0f61bfca7fdb5786672 (patch)
tree6f1019cfb74c4d02866bbba826c84d1d5f8a281e
parentc7ab89c6642f0e634547f4ed26eab079b31f06bc (diff)
downloadguix-bdb664f7b0df111b0ff5a0f61bfca7fdb5786672.tar
guix-bdb664f7b0df111b0ff5a0f61bfca7fdb5786672.tar.gz
gnu: network-manager: Use Meson option for modprobe.
* gnu/packages/gnome.scm (arguments): Replace the 'patch-modprobe-path phase with a ‘-Dmodprobe=’ configure flag.
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a48cbb58f3..57519a284b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8318,19 +8318,12 @@ users.")
#$output "/lib/udev")
(string-append "-Ddbus_conf_dir="
#$output "/etc/dbus-1/system.d")
-
+ (string-append "-Dmodprobe=" (search-input-file %build-inputs
+ "bin/modprobe"))
(string-append "-Ddhclient=" (search-input-file %build-inputs
"sbin/dhclient")))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'patch-modprobe-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/libnm-platform/nm-platform-utils.c"
- ;; The modprobe command location is not configurable (see:
- ;; https://gitlab.freedesktop.org/NetworkManager/
- ;; NetworkManager/-/issues/1257).
- (("/sbin/modprobe")
- (search-input-file inputs "bin/modprobe")))))
(add-after 'unpack 'patch-dlopen-call-to-libjansson.so
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/libnm-glib-aux/nm-json-aux.c"