aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 12:32:31 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 12:32:31 +0100
commitbad548161eb2f3e2d869812ed307e20f7583933e (patch)
treef7a2f9f613d280cf0ec3b0efd3b8dc4c9d96318c
parent6e8cdf1d26092cb9654e179b04730fff7c15c94f (diff)
downloadguix-bad548161eb2f3e2d869812ed307e20f7583933e.tar
guix-bad548161eb2f3e2d869812ed307e20f7583933e.tar.gz
gnu: emacs-scratch-el: Update to 1.3.
* gnu/packages/emacs-xyz.scm (emacs-scratch-el): Update to 1.3.
-rw-r--r--gnu/packages/emacs-xyz.scm62
1 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4d302a3f96..4aed2643fe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14425,42 +14425,40 @@ from @code{groovy-mode} for editing Jenkins declarative pipeline files.")
(license license:gpl3+))))
(define-public emacs-scratch-el
- (let ((commit "2cdf2b841ce7a0987093f65b0cc431947549f897")
- (revision "1"))
- (package
- (name "emacs-scratch-el")
- (version (git-version "1.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ieure/scratch-el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0wscsndynjmnliajqaz28r1ww81j8wh84zwaaswx51abhwgl0idf"))))
- (build-system emacs-build-system)
- (native-inputs
- `(("texinfo" ,texinfo)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (unless (invoke "makeinfo" "scratch.texi")
- (error "makeinfo failed"))
- (install-file "scratch.info"
- (string-append (assoc-ref outputs "out")
- "/share/info"))
- #t)))))
- (home-page "https://github.com/ieure/scratch-el/")
- (synopsis "Create scratch buffers with the same mode as current buffer")
- (description "Scratch is an extension to Emacs that enables one to create
+ (package
+ (name "emacs-scratch-el")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ieure/scratch-el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yiwq2gc4gdgfhaagpawhb7yrzc4fsnyb10w5d0q4whv64cj8555"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (unless (invoke "makeinfo" "scratch.texi")
+ (error "makeinfo failed"))
+ (install-file "scratch.info"
+ (string-append (assoc-ref outputs "out")
+ "/share/info"))
+ #t)))))
+ (home-page "https://github.com/ieure/scratch-el/")
+ (synopsis "Create scratch buffers with the same mode as current buffer")
+ (description "Scratch is an extension to Emacs that enables one to create
scratch buffers that are in the same mode as the current buffer. This is
notably useful when working on code in some language; you may grab code into a
scratch buffer, and, by virtue of this extension, do so using the Emacs
formatting rules for that language.")
- (license license:bsd-2))))
+ (license license:bsd-2)))
(define-public emacs-kv
(package