aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-09-07 23:24:42 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2024-02-23 22:05:38 +0100
commitb993bfa94fe8dad320a51b26db3a7c1760535aba (patch)
tree6393fdb580c33a419208dba722089e85f4e358f2
parentb386c11e7804e0b577411d930b60f1e0a4a0382c (diff)
downloadguix-b993bfa94fe8dad320a51b26db3a7c1760535aba.tar
guix-b993bfa94fe8dad320a51b26db3a7c1760535aba.tar.gz
gnu: Add roxterm.
* gnu/packages/terminals.scm (roxterm): New variable. Change-Id: I09b790a03214890fea0b5f87055989d80634d763
-rw-r--r--gnu/packages/terminals.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index ef187c6ced..e5acac202b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1706,3 +1706,30 @@ ephemeral serial ports. It features automatic port detection, port enumeration,
support for non-standard baud rates, the ability to wait for ports to appear,
and the ability to read and write via stdin and stdout.")
(license license:expat)))
+
+(define-public roxterm
+ (package
+ (name "roxterm")
+ (version "3.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/realh/roxterm.git")
+ (commit version)))
+ (sha256
+ (base32
+ "19y4lxwj18pr231597rnyyk6f5hwvsajjv7w21wb5c62jjjyfrws"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests
+ (native-inputs
+ (list docbook-xsl docbook-xml (list glib "bin") libxml2 libxslt
+ pkg-config))
+ (inputs
+ (list dbus dbus-glib gtk+ pcre vte))
+ (synopsis "ROXTerm terminal emulator")
+ (description "This package provides a terminal emulator with hyperlink
+support. It's based on VTE and aimed at power users.")
+ (home-page "https://realh.github.io/roxterm/")
+ ;; src/gresources.c is under LGPL 2.1+
+ (license (list license:gpl2+ license:lgpl2.1+))))