aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-25 09:48:13 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-25 09:48:13 +0200
commitb972db72751c508c4830aad38bb51ddc67ceab69 (patch)
treec4957e45307189c34aa6f0f094d9149832bba27a
parentf1dfb7c47c2cb7ca972d0379640838719af9a118 (diff)
downloadguix-b972db72751c508c4830aad38bb51ddc67ceab69.tar
guix-b972db72751c508c4830aad38bb51ddc67ceab69.tar.gz
gnu: fontconfig: Add and register gs-fonts.
* gnu/packages/fontutils.scm (fontconfig): Add gs-fonts as an input and register it in the configuration file; so any porgram using fontconfig should at least have the gs-fonts at its disposal.
-rw-r--r--gnu/packages/fontutils.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 8b5e9c582a..ac0dbdf9d5 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages fontutils)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml)
#:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
@@ -75,11 +76,16 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(build-system gnu-build-system)
(inputs `(("expat" ,expat)
("freetype" ,freetype)
+ ("gs-fonts" ,gs-fonts)
("pkg-config" ,pkg-config)))
(arguments
`(#:configure-flags
- ;; point to user profile instead of /usr/share/fonts in /etc/fonts.conf
- `("--with-default-fonts=~/.guix-profile/share/fonts")))
+ ;; point to user profile instead of /usr/share/fonts in /etc/fonts.conf
+ (list "--with-default-fonts=~/.guix-profile/share/fonts"
+ ;; register gs-fonts
+ (string-append "--with-add-fonts="
+ (assoc-ref %build-inputs "gs-fonts")
+ "/share/fonts"))))
(synopsis "Fontconfig, a library for configuring and customising font access.")
(description
"Fontconfig can discover new fonts when installed automatically;