aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:08:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:33 +0200
commitb93ad894503426d9439ac5c22237c6042ba9e8cf (patch)
tree9ec03f865a561e2a9cdafb49bcb1fbf5273d7f7d
parent2e241d5b04afd1b3887518a98ca10c957b8810c6 (diff)
downloadguix-b93ad894503426d9439ac5c22237c6042ba9e8cf.tar
guix-b93ad894503426d9439ac5c22237c6042ba9e8cf.tar.gz
gnu: Add texlive-expressg.
* gnu/packages/tex.scm (texlive-expressg): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 64f0dcb21a..3c6b389363 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5089,6 +5089,29 @@ remain in sequence).")
(define-deprecated-package texlive-latex-expdlist texlive-expdlist)
+(define-public texlive-expressg
+ (package
+ (name "texlive-expressg")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/expressg/"
+ "metapost/expressg/"
+ "source/metapost/expressg/")
+ (base32
+ "08f6lxxxmhfld6g2iy2kn68llalz3wayxqka7nd48s1ahm33kmdd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/expressg")
+ (synopsis "Diagrams consisting of boxes, lines, and annotations")
+ (description
+ "This package provides a MetaPost package providing facilities to assist
+in drawing diagrams that consist of boxes, lines, and annotations. Particular
+support is provided for creating EXPRESS-G diagrams, for example IDEF1X, OMT,
+Shlaer-Mellor, and NIAM diagrams. The package may also be used to create UML
+and most other Box-Line-Annotation charts, but not Gantt charts directly.")
+ (license license:lppl)))
+
(define-public texlive-filemod
(package
(name "texlive-filemod")