aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 14:41:27 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:37 +0000
commitb918cfe406be5e56d6fda3c61093a5988ff05ac8 (patch)
treeca42d093a1401416afbd1919a38fbb6e3329d009
parentcce001e3ce954384cfe00d6b1cc1e6a50192446f (diff)
downloadguix-b918cfe406be5e56d6fda3c61093a5988ff05ac8.tar
guix-b918cfe406be5e56d6fda3c61093a5988ff05ac8.tar.gz
gnu: python-ddt: Update to 1.7.2.
* gnu/packages/python-xyz.scm (python-ddt): Update to 1.7.2. [build-system]: Swap to pyrpoject-build-system. [native-inputs]: Add python-aiounittest, python-setuptools, and python-wheel. [description]: Fix fill column. Change-Id: I43655f16e978caa6d37981a2a01c2edd2b512875
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 34fe84d517..33a0045d25 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24709,25 +24709,27 @@ creating a tag.")
(define-public python-ddt
(package
(name "python-ddt")
- (version "1.4.2")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ddt" version))
(sha256
- (base32
- "0y2k756qjz1rhpivi60hy29b4bf0bh3wck39i1mn6pkil9k779k4"))))
- (build-system python-build-system)
+ (base32 "0jz0lglz5z5clsbralbpmd1hxs4ndb6ls7lvl7216c4nhfqdc5fj"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
+ (list python-aiounittest
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-pyyaml))
(home-page "https://github.com/datadriventests/ddt")
(synopsis "Data-Driven Tests")
(description
"Data-Driven Tests (@dfn{DDT}) allow you to multiply one test case by
- running it with different test data, and make it appear as multiple test
- cases.")
+running it with different test data, and make it appear as multiple test
+cases.")
(license license:expat)))
(define-public python-pycountry