aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-07-19 10:29:09 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-01 11:54:17 +0100
commitb66563931b7ed91405f814e17eeab6db36f82c47 (patch)
tree757986e4637218eb823ca507073112f3edaf2e3a
parentdd63cd7876f8c6a6eb42170219c17659ff4daf42 (diff)
downloadguix-b66563931b7ed91405f814e17eeab6db36f82c47.tar
guix-b66563931b7ed91405f814e17eeab6db36f82c47.tar.gz
gnu: Add r-gggenes.
* gnu/packages/cran.scm (r-gggenes): New variable. Change-Id: I6062ecc14a9e9af4f676b050983323bed27e6bfa
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 717e4eac89..66205781b1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26442,6 +26442,26 @@ inline CSS directives, and it can be rendered both with and without word
wrap.")
(license license:expat)))
+(define-public r-gggenes
+ (package
+ (name "r-gggenes")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gggenes" version))
+ (sha256
+ (base32 "08s0fhk2kz3ks64nfmdbd8p3swkn62cbw7dpbqgk9ydpmh5gpjbj"))))
+ (properties `((upstream-name . "gggenes")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggfittext r-ggplot2 r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://wilkox.org/gggenes/")
+ (synopsis "Draw gene arrow maps in ggplot2")
+ (description
+ "This package provides a ggplot2 extension for drawing gene arrow maps.")
+ (license license:gpl2)))
+
(define-public r-ggghost
(package
(name "r-ggghost")