aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:44:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:17 +0200
commitb4fd27a7e15b94d3d495dc79b99e621b2efeb8e8 (patch)
treecfeed696c37df55b4f2555f670a5cdddbe125ad1
parent2e3885e142e88b7f0fa5f81ea1a4b7b5057d66d8 (diff)
downloadguix-b4fd27a7e15b94d3d495dc79b99e621b2efeb8e8.tar
guix-b4fd27a7e15b94d3d495dc79b99e621b2efeb8e8.tar.gz
gnu: Add texlive-resolsysteme.
* gnu/packages/tex.scm (texlive-resolsysteme): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c3e33a3c4..58b81fac80 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5787,6 +5787,36 @@ functionals, c.e.@: sets, stagewise computations, forcing and syntactic
classes.")
(license license:public-domain)))
+(define-public texlive-resolsysteme
+ (package
+ (name "texlive-resolsysteme")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/resolsysteme/"
+ "tex/latex/resolsysteme/")
+ (base32
+ "0g51cmjd5gs0p198sb8v95l8jra6cv6smz2068b1pdpv1fqpmjfv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/resolsysteme")
+ (synopsis "Work on linear systems using xint or pyluatex")
+ (description
+ "This package provides some commands (in French) to perform calculations
+on small (2x2 or 3x3 or 4x4) linear systems, with @code{xint} or
+@code{pyluatex}:
+
+@itemize
+@item @code{\\DetMatrice} or @code{\\DetMatricePY} to diplay the determinant
+of a matrix;
+@item @code{\\MatriceInverse} or @code{\\MatriceInversePY} to display the
+inverse of a matrix;
+@item @code{\\SolutionSysteme} or @code{\\SolutionSystemePY} to display the
+solution of a linear system;
+@item @dots{}
+@end itemize")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")