aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-20 18:39:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-20 23:40:40 +0200
commitb4e37a3972b8e237214b52bf631fb6b69408e445 (patch)
tree26ffc13db81dc1f821410b6ec3252f9bc3168cdf
parent91e07cc5bf99fed2eafc7a067e10ca4414e10902 (diff)
downloadguix-b4e37a3972b8e237214b52bf631fb6b69408e445.tar
guix-b4e37a3972b8e237214b52bf631fb6b69408e445.tar.gz
gnu: tensorflow: Patch one more instance of "collections".
* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Add one more patch of "collections" to "collections.abc" to the 'python3.10-compatibility phase.
-rw-r--r--gnu/packages/machine-learning.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a3edbcb894..13651f4035 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2435,6 +2435,8 @@ Python.")
(substitute* "tensorflow/python/keras/callbacks.py"
(("from collections import Iterable")
"from collections.abc import Iterable"))
+ (substitute* "tensorflow/python/ops/variable_scope.py"
+ (("collections_lib.Sequence") "collections_lib.abc.Sequence"))
;; XXX: it is not clear if this is a good idea, but the build
;; system tries to overwrite the __or__ and __ror__ methods of
@@ -2453,7 +2455,7 @@ Python.")
"void CompareUFunc(char** args, npy_intp const* dimensions, npy_intp const* steps,"))
;; ...and for numpy >= 1.23
- (substitute* '("tensorflow/python/framework/tensor_util.py")
+ (substitute* "tensorflow/python/framework/tensor_util.py"
(("np.asscalar\\(x\\[0\\]\\)") "x[0].item()")
(("np.asscalar\\(x\\)") "x.item()")
(("np.asscalar\\(v\\)") "np.ndarray.item(v)")