aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-11 21:22:50 +0200
committerMarius Bakke <marius@gnu.org>2022-08-12 00:22:28 +0200
commitb4a7f8c917fa9a9f2513a49e00961fd11e09ca31 (patch)
treeafdb6891d04d40917ff3b2f4ea39eb67873794d9
parent32800e5eb654cd84d69bff056ed7e0285ec8c69f (diff)
downloadguix-b4a7f8c917fa9a9f2513a49e00961fd11e09ca31.tar
guix-b4a7f8c917fa9a9f2513a49e00961fd11e09ca31.tar.gz
gnu: Remove librsvg-bootstrap.
librsvg is already a staging-level package, and the next version will no longer bundle its dependencies, so we might as well drop it early. * gnu/packages/gnome.scm (librsvg-bootstrap): Remove variable. * gnu/packages/bittorrent.scm (deluge)[native-inputs]: Replace LIBRSVG-BOOTSTRAP with LIBRSVG. * gnu/packages/emacs.scm (emacs)[inputs]: Likewise. * gnu/packages/gtk.scm (gtk+-2)[propagated-inputs]: Likewise. * gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Likewise.
-rw-r--r--gnu/packages/bittorrent.scm2
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/gnome.scm21
-rw-r--r--gnu/packages/gtk.scm4
4 files changed, 4 insertions, 25 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 43fc287b95..fcb59368e9 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -525,7 +525,7 @@ features.")
(native-inputs
(list intltool python-wheel
(if (string-prefix? "x86_64-" (%current-system))
- librsvg-bootstrap
+ librsvg
librsvg-2.40)))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ffd1eda08e..995fbd8dd3 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -289,7 +289,7 @@
libpng
zlib
(if (target-x86-64?)
- librsvg-bootstrap
+ librsvg
librsvg-2.40)
libxpm
libxml2
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 27d2a58e65..491b21d5ca 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3532,27 +3532,6 @@ diagrams.")
(home-page "https://wiki.gnome.org/LibRsvg")
(license license:lgpl2.1+)))
-;; This copy of librsvg uses the bundled rust libraries. It is useful for
-;; packages which have too many dependencies to be rebuilt as frequently
-;; as the rust inputs are updated.
-;; TODO: Remove this package and use packaged rust libraries!
-(define-public librsvg-bootstrap
- (package
- (inherit librsvg)
- (name "librsvg-bootstrap")
- (source (origin
- (inherit (package-source librsvg))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file (find-files "vendor" "\\.a$"))))))
- (arguments
- (substitute-keyword-arguments (package-arguments librsvg)
- ((#:vendor-dir _ "vendor") "vendor")
- ((#:cargo-inputs _) '())
- ((#:cargo-development-inputs _) '())))
- (properties '((hidden? . #t)))))
-
(define-public librsvg-2.40
;; This is the last version implemented in C.
(package
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 18531ec5f7..c0ea89d406 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -872,7 +872,7 @@ is part of the GNOME accessibility project.")
(propagated-inputs
(list atk cairo
(if (target-x86-64?)
- librsvg-bootstrap
+ librsvg
librsvg-2.40)
glib pango))
(inputs
@@ -971,7 +971,7 @@ application suites.")
fontconfig
freetype
(if (target-x86-64?)
- librsvg-bootstrap
+ librsvg
librsvg-2.40)
glib
libcloudproviders-minimal