aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 16:18:16 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:22 +0000
commitaf1e95b7dfb17b0038d24d32cd379a649215b658 (patch)
treea27d8fb9ecc201e4a9421cc3584d53bbc71572c7
parentff0f9ab7d683131a70fa9c0bbb7baebc31d8ba6a (diff)
downloadguix-af1e95b7dfb17b0038d24d32cd379a649215b658.tar
guix-af1e95b7dfb17b0038d24d32cd379a649215b658.tar.gz
gnu: gedit: Update to 40.1.
* gnu/packages/gnome.scm (gedit): Update to 40.1. [source]: Fix the URI. [inputs]: Add amtk and tepl.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a7e4561204..35c4a77b64 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7238,15 +7238,15 @@ javascript engine and the GObject introspection framework.")
(define-public gedit
(package
(name "gedit")
- (version "3.34.1")
+ (version "40.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1inm50sdfw63by1lf4f1swb59mpyxlly0g5rdg99j5l3357fzygb"))))
+ "149ngl9qw6h59546lir1pa7hvw23ppsnqlj9mfqphmmn5jl99qsm"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -7308,7 +7308,8 @@ javascript engine and the GObject introspection framework.")
(base32 "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs"))))
("pkg-config" ,pkg-config)))
(inputs
- `(("glib" ,glib)
+ `(("amtk" ,amtk)
+ ("glib" ,glib)
("gspell" ,gspell)
("gtk+" ,gtk+)
("gtksourceview" ,gtksourceview)
@@ -7317,6 +7318,7 @@ javascript engine and the GObject introspection framework.")
("iso-codes" ,iso-codes)
("python-pygobject" ,python-pygobject)
("python" ,python)
+ ("tepl" ,tepl)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("libx11" ,libx11)
("vala" ,vala)