aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:36:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:21 +0200
commita87ed15e1dee32d94e12714ac0d939a2466125b7 (patch)
treea1249aad12ab4930567eafa877f7ab4d21711081
parentde69da218e87da09e857d29e54b4b5edc53c9e6e (diff)
downloadguix-a87ed15e1dee32d94e12714ac0d939a2466125b7.tar
guix-a87ed15e1dee32d94e12714ac0d939a2466125b7.tar.gz
gnu: Add texlive-chemstyle.
* gnu/packages/tex.scm (texlive-chemstyle): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2e2e36d8ea..9968b8bd52 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2465,6 +2465,27 @@ on the first occurence in the document and just labels only on subsequent
references.")
(license license:lppl1.3+)))
+(define-public texlive-chemstyle
+ (package
+ (name "texlive-chemstyle")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/chemstyle/"
+ "source/latex/chemstyle/"
+ "tex/latex/chemstyle/")
+ (base32
+ "1s2k4h153yh0f50q9da390f3ihykvrhsd1zjgfsdb6404059in3p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/chemstyle")
+ (synopsis "Writing chemistry with style")
+ (description
+ "The package @code{chemstyle} provides an extensible system for
+formatting chemistry documents according to the conventions of a number of
+leading journals. It also provides some handy chemistry-related macros.")
+ (license license:lppl1.3+)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")