aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-18 10:57:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 10:57:12 +0200
commita870b80046d532329762095683d8f9c33538eaf1 (patch)
treebe3ef1de525a0ad3ebf44c2726691bda5bcaaf68
parentdfcf79ac5943c68dc8013aa333add3f881e894aa (diff)
downloadguix-a870b80046d532329762095683d8f9c33538eaf1.tar
guix-a870b80046d532329762095683d8f9c33538eaf1.tar.gz
gnu: festival: Fix scripts.
* gnu/packages/speech.scm (festival)[arguments]: Fix broken shebangs in scripts.
-rw-r--r--gnu/packages/speech.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 220d542eda..21d6027004 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -350,17 +350,23 @@ be used by the sighted.")
(install-file executable bin))
'("src/main/festival"
"src/main/festival_client"
- "examples/benchmark"
- "examples/dumpfeats"
- "examples/durmeanstd"
- "examples/latest"
- "examples/make_utts"
- "examples/powmeanstd"
- "examples/run-festival-script"
- "examples/saytime"
- "examples/scfg_parse_text"
- "examples/text2pos"
- "examples/text2wave"))
+ "examples/benchmark"))
+ (let ((scripts '("examples/dumpfeats"
+ "examples/durmeanstd"
+ "examples/latest"
+ "examples/make_utts"
+ "examples/powmeanstd"
+ "examples/run-festival-script"
+ "examples/saytime"
+ "examples/scfg_parse_text"
+ "examples/text2pos"
+ "examples/text2wave")))
+ (substitute* scripts
+ (("exec /tmp/guix-build.*/bin/festival")
+ (string-append "exec " bin "/festival")))
+ (for-each (lambda (script)
+ (install-file script bin))
+ scripts))
;; Documentation
(for-each (lambda (file)