aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-20 20:57:19 +0100
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commita811fb219baee870bc98ff5e7cd1fab43ec7be91 (patch)
tree3f53c9d65aae6934320709a9d978da6f840a0dc0
parentd05abc18bf15c5cdad2a2957c02d7604601fe8cc (diff)
downloadguix-a811fb219baee870bc98ff5e7cd1fab43ec7be91.tar
guix-a811fb219baee870bc98ff5e7cd1fab43ec7be91.tar.gz
gnu: python-botocore: Update to 1.19.22.
* gnu/packages/python-xyz.scm (python-botocore): Update to 1.19.22. [propagated-inputs]: Remove PYTHON-DOCUTILS. Add PYTHON-URLLIB3.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cc2a710dee..52b45e9bb4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10983,22 +10983,22 @@ manipulation library.")
;; are compatible.
(package
(name "python-botocore")
- (version "1.15.26")
+ (version "1.19.22")
(source
(origin
(method url-fetch)
(uri (pypi-uri "botocore" version))
(sha256
(base32
- "1a87pbwkk5vlwz92hy1wizfnpiwn11bhaicr6bmji1i5ybwdhnr8"))))
+ "0iim86x7c6hqmvd61ygz6x6x9glnsfbnyzv2y67qjdcdx8jpkmw7"))))
(build-system python-build-system)
(arguments
;; FIXME: Many tests are failing.
'(#:tests? #f))
(propagated-inputs
`(("python-dateutil" ,python-dateutil)
- ("python-docutils" ,python-docutils)
- ("python-jmespath" ,python-jmespath)))
+ ("python-jmespath" ,python-jmespath)
+ ("python-urllib3" ,python-urllib3)))
(home-page "https://github.com/boto/botocore")
(synopsis "Low-level interface to AWS")
(description "Botocore is a Python library that provides a low-level