aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-09-11 11:57:32 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2024-10-12 11:02:51 +0200
commita531af142ffdb2a31cf9e6258c336fcf2dbe755b (patch)
tree9071952a4df685f2120cfd40970b687586f48fd8
parentb7a4ce82ec246a17d7f53d6fba34b14863858ea0 (diff)
downloadguix-a531af142ffdb2a31cf9e6258c336fcf2dbe755b.tar
guix-a531af142ffdb2a31cf9e6258c336fcf2dbe755b.tar.gz
gnu: lablgtk: Remove variable.
* gnu/packages/ocaml.scm (lablgtk): Package is no longer used as a dependency. Change-Id: I7e3d1e5c0bd65a4938b0e08012094603d9d55cc5
-rw-r--r--gnu/packages/ocaml.scm66
1 files changed, 0 insertions, 66 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 804c51c5b0..9d29105cdb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1404,72 +1404,6 @@ Knuth’s LR(1) parser construction technique.")
@code{Stdlib.Bigarray} in OCaml.")
(license license:isc)))
-(define-public lablgtk
- (package
- (name "lablgtk")
- (version "2.18.11")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/garrigue/lablgtk")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "179ipx0c6bpxm4gz0syxgqy09dp5p4x9qsdil7s9jlx8ffg1mm0w"))))
- (build-system gnu-build-system)
- (native-inputs
- (list ;; Build failure with make-4.4, so we use make-4.2.
- ;; See <https://github.com/garrigue/lablgtk/issues/170>.
- gnu-make-4.2
- ocaml
- ocaml-findlib
- pkg-config))
- ;; FIXME: Add inputs gtkgl-2.0, libpanelapplet-2.0, gtkspell-2.0,
- ;; and gtk+-quartz-2.0 once available.
- (inputs
- (list gtk+-2
- gtksourceview-2
- libgnomecanvas
- libgnomeui
- libglade
- (librsvg-for-system)))
- (arguments
- `(#:tests? #f ; no check target
-
- ;; opt: also install cmxa files
- #:make-flags (list "all" "opt"
- (string-append "FINDLIBDIR="
- (assoc-ref %outputs "out")
- "/lib/ocaml"))
- ;; Occasionally we would get "Error: Unbound module GtkThread" when
- ;; compiling 'gtkThInit.ml', with 'make -j'. So build sequentially.
- #:parallel-build? #f
-
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'prepare-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (ocaml (assoc-ref inputs "ocaml")))
- ;; Install into the output and not the ocaml directory.
- (mkdir-p (string-append out "/lib/ocaml"))
- (substitute* "config.make"
- ((ocaml) out))
- #t))))))
- (home-page "http://lablgtk.forge.ocamlcore.org/")
- (synopsis "GTK+ bindings for OCaml")
- (description
- "LablGtk is an OCaml interface to GTK+ 1.2 and 2.x. It provides
-a strongly-typed object-oriented interface that is compatible with the
-dynamic typing of GTK+. Most widgets and methods are available. LablGtk
-also provides bindings to
-gdk-pixbuf, the GLArea widget (in combination with LablGL), gnomecanvas,
-gnomeui, gtksourceview, gtkspell,
-libglade (and it an generate OCaml code from .glade files),
-libpanel, librsvg and quartz.")
- (license license:lgpl2.1)))
-
(define-public binsec
(package
(name "binsec")