aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-31 14:31:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:29 +0300
commita40e385a11144ae1a7ed060b3d55a71c023901ce (patch)
tree5f710eff363de08a6d581ea826701e07886c48e7
parente420b090decccb1ff20b143af4de2ddb9cbb6e00 (diff)
downloadguix-a40e385a11144ae1a7ed060b3d55a71c023901ce.tar
guix-a40e385a11144ae1a7ed060b3d55a71c023901ce.tar.gz
gnu: Add rust-lazy-regex-proc-macros-3.
* gnu/packages/crates-io.scm (rust-lazy-regex-proc-macros-3): New variable. Change-Id: Iacd350e068cd1b7e7cd9315451984838414606cb
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 64190f1090..b92f7ad4c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36068,6 +36068,29 @@ generated by LALRPOP.")
"This crate provides simple methods to cast from and into byte arrays.")
(license license:boost1.0)))
+(define-public rust-lazy-regex-proc-macros-3
+ (package
+ (name "rust-lazy-regex-proc-macros")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lazy-regex-proc_macros" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02zgaxdq95s0xm4svbdz6f4xkf4kncl5gjfdzyxgr9wpdj7dbg24"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; cannot find macro `regex_replace_all` in this scope
+ #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/Canop/lazy-regex")
+ (synopsis "Proc macros for the lazy_regex crate")
+ (description "This package provides proc macros for the lazy_regex crate.")
+ (license license:expat)))
+
(define-public rust-lazy-static-1
(package
(name "rust-lazy-static")