aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 23:29:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 23:29:29 +0100
commit9f3e8c045f4c8fb652fa8da0705a41eb60f05808 (patch)
tree902af10064717c03e6c37182c413f95fc0889831
parent60c96b2f77174e46bf1584aed07e662eade2c70a (diff)
downloadguix-9f3e8c045f4c8fb652fa8da0705a41eb60f05808.tar
guix-9f3e8c045f4c8fb652fa8da0705a41eb60f05808.tar.gz
gnu: go-github-com-emersion-go-message: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-message): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I63e5b4d52142e90e64bdbf4f31cec9e18d221c24
-rw-r--r--gnu/packages/golang-web.scm25
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3665ab73c3..007af4ef7c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -677,6 +677,31 @@ and stop increasing when a certain threshold is met.")
go-golang-org-x-net
go-golang-org-x-oauth2))))
+(define-public go-github-com-emersion-go-message
+ (package
+ (name "go-github-com-emersion-go-message")
+ (version "0.18.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-message")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gzcgrs5sava8fpybp5cw6f3zqnbz096wf93hcgkrg94wl1g7kqb"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/emersion/go-message"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (home-page "https://github.com/emersion/go-message")
+ (synopsis "Internet messages and MIME for Go")
+ (description
+ "The message package implements the Internet Message Format and
+Multipurpose Internet Mail Extensions in Go.")
+ (license license:expat)))
+
(define-public go-github-com-emicklei-go-restful
(package
(name "go-github-com-emicklei-go-restful")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4738179bce..cc032fb021 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8625,31 +8625,6 @@ result is a conceptually simple, but highly performant, disk-backed storage syst
email library.")
(license license:gpl3+)))
-(define-public go-github-com-emersion-go-message
- (package
- (name "go-github-com-emersion-go-message")
- (version "0.18.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-message")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0gzcgrs5sava8fpybp5cw6f3zqnbz096wf93hcgkrg94wl1g7kqb"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/emersion/go-message"))
- (propagated-inputs
- (list go-golang-org-x-text))
- (home-page "https://github.com/emersion/go-message")
- (synopsis "Internet messages and MIME for Go")
- (description
- "The message package implements the Internet Message Format and Multipurpose
-Internet Mail Extensions in Go.")
- (license license:expat)))
-
(define-public go-github-com-jaytaylor-html2text
(package
(name "go-github-com-jaytaylor-html2text")