aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:18:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:18:21 +0200
commit9dc1c330bde536e2099d42a9c36babf83f098717 (patch)
treed9d85fb220c0339b81a84aee0f75b55f15e7d586
parented601538b78b00768516c2d352c214df053c6a0e (diff)
downloadguix-9dc1c330bde536e2099d42a9c36babf83f098717.tar
guix-9dc1c330bde536e2099d42a9c36babf83f098717.tar.gz
gnu: Add texlive-luatexja.
* gnu/packages/tex.scm (texlive-luatexja): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bb9dbd886e..253b9e34fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23998,6 +23998,27 @@ upgrade smoothly to the new support structure.")
"The package provides emulation of pdfTeX primitives for LuaTeX v0.85+.")
(license license:lppl1.3+)))
+(define-public texlive-luatexja
+ (package
+ (name "texlive-luatexja")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/luatexja/"
+ "source/luatex/luatexja/"
+ "tex/luatex/luatexja/")
+ (base32
+ "1j4dvzxgjyx5aa7akg5wg2w694vds6ra70zk9crrlm83aryqkda7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-luatexbase))
+ (home-page "https://ctan.org/pkg/luatexja")
+ (synopsis "Typeset Japanese with Lua(La)TeX")
+ (description
+ "The package offers support for typesetting Japanese documents with LuaTeX.
+Either of the Plain and LaTeX2e formats may be used with the package.")
+ (license license:bsd-3)))
+
(define-public texlive-luahbtex
(package
(name "texlive-luahbtex")