aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-05-13 20:52:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-24 10:59:58 +0100
commit9d577f0f4c6a4f6df03bb6e8c0a845c2dcd6d65a (patch)
tree32a522f909e880e8eb1b784df0f36c5d51162548
parent64ed49873784e5ef9d78b23a52354e3e6f9a63c8 (diff)
downloadguix-9d577f0f4c6a4f6df03bb6e8c0a845c2dcd6d65a.tar
guix-9d577f0f4c6a4f6df03bb6e8c0a845c2dcd6d65a.tar.gz
gnu: Add python-primecountpy.
* gnu/packages/maths.scm (python-primecountpy): New variable. Change-Id: Id775a672c104162965825d8d44e599df0c26f11a Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/maths.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 50d517f834..4c526113f0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4046,6 +4046,35 @@ message-passing communication. @code{petsc4py} provides Python
bindings to almost all functions of PETSc.")
(license license:bsd-3)))
+(define-public python-primecountpy
+ (package
+ (name "python-primecountpy")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "primecountpy" version))
+ (sha256
+ (base32 "0xh6zx5zw5scy7jygqirks9y6z4zyfm0zjfp8nd6dw0m471przkq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (native-inputs
+ (list python-cysignals
+ python-cython
+ python-setuptools))
+ (inputs
+ (list pari-gp
+ primecount
+ primesieve))
+ (home-page "https://github.com/dimpase/primecountpy")
+ (synopsis "Cython interface for C++ primecount library")
+ (description "This package provides a Cython interface to the C++ library
+@code{primecount}.")
+ ;; pyproject.toml says gpl3 but file headers say gpl2+, see
+ ;; <https://github.com/dimpase/primecountpy/issues/16>.
+ (license license:gpl2+)))
+
(define-public python-quadpy
(package
(name "python-quadpy")