aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-10-26 17:02:29 -0400
committerMarius Bakke <mbakke@fastmail.com>2017-10-27 00:42:06 +0200
commit9d0866ce1b85c3433552627909dd67aba64814f7 (patch)
tree7d9ecbe48a65e85acfd3e204924ec4bae85ece31
parentb89e3c77c683626b3c747245926483692abde9f6 (diff)
downloadguix-9d0866ce1b85c3433552627909dd67aba64814f7.tar
guix-9d0866ce1b85c3433552627909dd67aba64814f7.tar.gz
gnu: Add python-ratelimiter.
* gnu/packages/python.scm (python-ratelimiter, python2-ratelimiter): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3f92da44d0..fed7394d78 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16843,3 +16843,27 @@ interpreter when it prints a stack trace.")
(define-public python2-traceback2
(package-with-python2 python-traceback2))
+
+(define-public python-ratelimiter
+ (package
+ (name "python-ratelimiter")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ratelimiter" version))
+ (sha256
+ (base32
+ "1dhz85mj5bqd2mij84ncs6pz32hgidr79hay4aqfmzaa4rbb497p"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; There are no tests in the pypi archive.
+ (home-page "https://github.com/RazerM/ratelimiter")
+ (synopsis "Simple rate limiting object")
+ (description
+ "The @code{ratelimiter} module ensures that an operation will not be
+executed more than a given number of times during a given period.")
+ (license license:asl2.0)))
+
+(define-public python2-ratelimiter
+ (package-with-python2 python-ratelimiter))