aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:38:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:09 +0200
commit9c2a372b3990fb9c1fb0eff4d562f37808e462b1 (patch)
treee23034ad179e1be4e4a1f2a89ae25fbdb345bf22
parent06cda1cb79acdf548d94297340d6811d85bae79e (diff)
downloadguix-9c2a372b3990fb9c1fb0eff4d562f37808e462b1.tar
guix-9c2a372b3990fb9c1fb0eff4d562f37808e462b1.tar.gz
gnu: Add texlive-pfdicons.
* gnu/packages/tex.scm (texlive-pfdicons): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 33cee1e3d1..a1947581b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5377,6 +5377,28 @@ will behave in the same way. The package also offers a robust
reimplementation of @code{\\big}, @code{\\bigg}, etc.")
(license license:lppl1.3+)))
+(define-public texlive-pfdicons
+ (package
+ (name "texlive-pfdicons")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pfdicons/" "tex/latex/pfdicons/")
+ (base32
+ "16xdy0ah7za1gr63w1pdfvbq8x4fkin7q0yfpml7y4wv7m1qxqgc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pfdicons")
+ (synopsis "Draw process flow diagrams in chemical engineering")
+ (description
+ "This package provides TikZ shapes to represent commonly encountered unit
+operations for depiction in process flow diagrams (PFDs) and, to a lesser
+extent, process and instrumentation diagrams (PIDs). The package was designed
+with undergraduate chemical engineering students and faculty in mind, and the
+number of units provided should cover--in Turton's estimate--about 90 percent
+of all fluid processing operations.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")