aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-21 13:28:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commit9b8d1003c1fa73a5e33cc0d6eb2babc82af29970 (patch)
treec93d3782309a735eed290c6792b8f455b655a8d1
parent2a8637107c084f121f45e76c16680d123646eab7 (diff)
downloadguix-9b8d1003c1fa73a5e33cc0d6eb2babc82af29970.tar
guix-9b8d1003c1fa73a5e33cc0d6eb2babc82af29970.tar.gz
gnu: go-github-com-prometheus-client-model: Move to prometheus.
* gnu/packages/golang-xyz.scm (go-github-com-prometheus-client-model): Move from here ... * gnu/packages/prometheus.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages prometheus) module. * gnu/packages/networking.scm: Likewise. Change-Id: Ibbfc4100dfe33f9524eee99a461e7760f06a8eb3
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm1
-rw-r--r--gnu/packages/networking.scm1
-rw-r--r--gnu/packages/prometheus.scm35
4 files changed, 36 insertions, 29 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4749fd5698..f007542b8a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4232,34 +4232,6 @@ Pion}.")
"@code{refmt} is a serialization and object-mapping library.")
(license license:expat)))
-(define-public go-github-com-prometheus-client-model
- (package
- (name "go-github-com-prometheus-client-model")
- (version "0.6.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/client_model")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0g1q2szzwp4rwkvayi2mnq2nwj6hj4ja7j43vwyi1iaz6d9z505c"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/client_model"
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-golang-protobuf))
- (synopsis "Data model artifacts for Prometheus")
- (description "This package provides data model artifacts for Prometheus.")
- (home-page "https://github.com/prometheus/client_model")
- (license license:asl2.0)))
-
(define-public go-github-com-pterm-pterm
(package
(name "go-github-com-pterm-pterm")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f83e62b44c..3b84e98b03 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -96,6 +96,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages prometheus)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages ruby)
#:use-module (gnu packages terminals)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8b93aaf443..64587ed3e1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -161,6 +161,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages prometheus)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index e898602ea0..6ab034c20a 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,7 +23,8 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
- #:use-module (gnu packages))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages golang-build))
;;; Commentary:
;;;
@@ -36,6 +39,36 @@
;;; Libraries:
;;;
+(define-public go-github-com-prometheus-client-model
+ (package
+ (name "go-github-com-prometheus-client-model")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_model")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g1q2szzwp4rwkvayi2mnq2nwj6hj4ja7j43vwyi1iaz6d9z505c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/prometheus/client_model"
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-golang-protobuf))
+ (home-page "https://github.com/prometheus/client_model")
+ (synopsis "Data model artifacts for Prometheus")
+ (description
+ "This package provides data model artifacts for Prometheus.")
+ (license license:asl2.0)))
+
;;;
;;; Executables:
;;;