aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:56:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commit969d0c6454f6906f9a6f3c6017623e61f16a979d (patch)
tree5803475b9524fa867f5fabdfbfea0cb8d2394c19
parent14e9a3971714365136bca777465771066f5afadd (diff)
downloadguix-969d0c6454f6906f9a6f3c6017623e61f16a979d.tar
guix-969d0c6454f6906f9a6f3c6017623e61f16a979d.tar.gz
gnu: ghc-blaze-markup: Update to 0.8.2.0.
* gnu/packages/haskell.scm (ghc-blaze-markup): Update to 0.8.2.0. [arguments]: Enable tests. [native-inputs]: Add ghc-hunit, ghc-quickcheck, ghc-tasty, ghc-tasty-hunit, and ghc-tasty-quickcheck.
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 37b5417a48..2eb8f8722a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3821,22 +3821,26 @@ interoperate with code that uses the new implementation.")
(define-public ghc-blaze-markup
(package
(name "ghc-blaze-markup")
- (version "0.7.0.3")
+ (version "0.8.2.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/blaze-markup/blaze-markup-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "blaze-markup/blaze-markup-"
+ version ".tar.gz"))
(sha256
(base32
- "080vlhd8dwjxrma4bb524lh8gxs5lm3xh122icy6lnnyipla0s9y"))))
+ "0m3h3ryxj5r74mv5g5dnfq5jbbwmvkl7ray18vi20d5vd93sydj4"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
(inputs
`(("ghc-blaze-builder" ,ghc-blaze-builder)
("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "http://jaspervdj.be/blaze")
(synopsis "Fast markup combinator library for Haskell")
(description "This library provides core modules of a markup combinator