aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-20 08:17:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:58 +0100
commit96998167c26cddbf44129cbf9955871b3fedaee9 (patch)
tree21c0f856aa2a95fdd69b3356801acb2e3de9568a
parent1bf612376574baa8771d6cc88285e30fa877aeaa (diff)
downloadguix-96998167c26cddbf44129cbf9955871b3fedaee9.tar
guix-96998167c26cddbf44129cbf9955871b3fedaee9.tar.gz
gnu: go-golang-org-x-exp: Adjust package style.
* gnu/packages/golang-build.scm (go-golang-org-x-exp): Fix indentation, apply list style. [description]: Place the sentence on a new line. Change-Id: I79d4682dc8ca0e5f0826f7e32c6dd01fc58aca44
-rw-r--r--gnu/packages/golang-build.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 88665490bb..d1977d36c8 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -262,28 +262,30 @@ language.")
(base32 "0ccjgv19w5p9sbcq12czmfnkjwv3b7hfljifwax6r9wk4dx0fcn7"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Submodules with their own go.mod files and packed as separated
- ;; packages:
- ;;
- ;; - golang.org/x/exp/event
- ;; - golang.org/x/exp/jsonrpc2
- ;; - golang.org/x/exp/shiny
- ;; - golang.org/x/exp/sumbdb
- ;; - golang.org/x/exp/typeparams
- (for-each delete-file-recursively
- (list "event" "jsonrpc2" "shiny" "sumdb" "typeparams"))))))
+ #~(begin
+ ;; Submodules with their own go.mod files and packed as separated
+ ;; packages:
+ ;;
+ ;; - golang.org/x/exp/event
+ ;; - golang.org/x/exp/jsonrpc2
+ ;; - golang.org/x/exp/shiny
+ ;; - golang.org/x/exp/sumbdb
+ ;; - golang.org/x/exp/typeparams
+ (for-each delete-file-recursively
+ (list "event" "jsonrpc2" "shiny" "sumdb" "typeparams"))))))
(build-system go-build-system)
(arguments
- '(#:import-path "golang.org/x/exp"
- ;; Source-only package
- #:tests? #f
- #:phases (modify-phases %standard-phases
- (delete 'build))))
+ (list
+ #:import-path "golang.org/x/exp"
+ ;; Source-only package
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (delete 'build))))
(home-page "https://golang.org/x/exp")
(synopsis "Experimental and deprecated Go packages")
- (description "This subrepository holds experimental and deprecated (in the
-@code{old} directory) packages.")
+ (description
+ "This subrepository holds experimental and deprecated (in the @code{old}
+directory) packages.")
(license license:bsd-3)))
(define-public go-golang-org-x-exp-typeparams