aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-04 09:27:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-06 11:36:10 -0400
commit93ccf08b4a168c0f8beb850f7c856a46c7be5c7e (patch)
tree3a03a7282127965d3f72003b5e74379849b2a564
parentab3731d255ff1ac8d6874bc0f68ad94f21f08e79 (diff)
downloadguix-93ccf08b4a168c0f8beb850f7c856a46c7be5c7e.tar
guix-93ccf08b4a168c0f8beb850f7c856a46c7be5c7e.tar.gz
gnu: gnurl: Deprecate in favor of curl.
gnurl is no longer maintained, is abandoned by upstream (see: https://bugs.gnunet.org/view.php?id=8684#c22105). * gnu/packages/gnunet.scm (gnurl): Alias to curl. Change-Id: I7829ac03c516b666e1ab96444cc45c852f065f90
-rw-r--r--gnu/packages/gnunet.scm68
1 files changed, 2 insertions, 66 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index c76e51ced0..0763361b9c 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -79,6 +79,7 @@
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu))
@@ -188,72 +189,7 @@ authentication and support for SSL3 and TLS.")
(license license:lgpl2.1+)
(home-page "https://www.gnu.org/software/libmicrohttpd/")))
-(define-public gnurl
- (package
- (name "gnurl")
- (version "7.72.0")
- ;; Fetch from git, as the tarball causes the build to fail with "No rule
- ;; to make target 'convsrctest.pl', needed by 'all-am'." (see
- ;; https://bugs.gnunet.org/view.php?id=8684).
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.taler.net/gnurl.git")
- (commit (string-append name "-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0b3jqxlarkiphf71i50vnvsmr8gh38ishrxqqbq77m0hjwyx4kv1"))))
- (build-system gnu-build-system)
- (outputs '("out"
- "doc")) ; 1.8 MiB of man3 pages
- (arguments
- (list
- #:test-target "test-nonflaky" ;do not run flaky tests
- #:configure-flags
- ;; All of these produce errors during configure.
- #~(list "--disable-ftp"
- "--disable-file"
- "--disable-ldap"
- "--disable-rtsp"
- "--disable-dict"
- "--disable-telnet"
- "--disable-tftp"
- "--disable-pop3"
- "--disable-imap"
- "--disable-smb"
- "--disable-smtp"
- "--disable-gopher"
- "--without-ssl"
- "--without-libpsl"
- "--without-librtmp"
- "--disable-ntlm-wb")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda _
- (substitute* "tests/runtests.pl.in"
- (("/bin/sh")
- (which "sh")))))
- (add-after 'install 'move-man3-pages
- (lambda _
- ;; Move section 3 man pages to "doc".
- (mkdir-p (string-append #$output:doc "/share/man"))
- (rename-file (string-append #$output "/share/man/man3")
- (string-append #$output:doc "/share/man/man3")))))))
- (native-inputs (list autoconf automake libtool perl pkg-config python))
- (inputs (list gnutls/dane libidn2 zlib))
- (synopsis
- "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
- (description
- "Gnurl is a microfork of cURL, a command line tool for transferring data
-with URL syntax. While cURL supports many crypto backends, libgnurl only
-supports HTTP, HTTPS and GnuTLS.")
- (license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))
- (properties '((ftp-server . "ftp.gnu.org")
- (ftp-directory . "/gnunet")))
- (home-page "https://gnunet.org/en/gnurl.html")))
+(define-deprecated/public-alias gnurl curl)
(define-public gnunet
(package