aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-25 15:16:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:55 +0000
commit8ee3669af48d78c919b42b124eb05d7d2bf2a2d0 (patch)
tree318f554ac8244cd9e2def068f4c75783b0a45bec
parent37ef7683de5f3f93c1dbbb15f78e02d4c6831089 (diff)
downloadguix-8ee3669af48d78c919b42b124eb05d7d2bf2a2d0.tar
guix-8ee3669af48d78c919b42b124eb05d7d2bf2a2d0.tar.gz
gnu: go-github-com-dustin-go-humanize: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-dustin-go-humanize): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/uucp.scm: Add golang-xyz module. Change-Id: Ic0913615d559ec255bf98abfab99383edf3c9a84
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm24
-rw-r--r--gnu/packages/uucp.scm1
3 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 832e56b042..00361fec30 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Guix Together <jgart@dismail.de>
@@ -2399,6 +2400,30 @@ Implements string conversion functionality for unit prefixes.
scanner API made public.")
(license license:bsd-3)))
+(define-public go-github-com-dustin-go-humanize
+ (package
+ (name "go-github-com-dustin-go-humanize")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dustin/go-humanize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iyhd90pnmxh64nhsh6k02c1b1glpmhh4whga9jgb9g0i5hz3sya"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dustin/go-humanize"))
+ (home-page "https://github.com/dustin/go-humanize")
+ (synopsis "Humane unit formatter")
+ (description
+ "@code{go-humanize} provides formatters for units to human friendly
+sizes. It converts boring ugly numbers to human-friendly strings and back.")
+ (license license:expat)))
+
(define-public go-github-com-edsrzf-mmap-go
(package
(name "go-github-com-edsrzf-mmap-go")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5402adf0fa..7dd5d93097 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6905,30 +6905,6 @@ the External Data Representation (XDR) standard protocol as specified in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
-(define-public go-github-com-dustin-go-humanize
- (package
- (name "go-github-com-dustin-go-humanize")
- (version "1.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dustin/go-humanize")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1iyhd90pnmxh64nhsh6k02c1b1glpmhh4whga9jgb9g0i5hz3sya"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/dustin/go-humanize"))
- (home-page "https://github.com/dustin/go-humanize")
- (synopsis "Humane unit formatter")
- (description "@code{go-humanize} provides formatters for units to human
-friendly sizes. It converts boring ugly numbers to human-friendly strings and
-back.")
- (license license:expat)))
-
(define-public go-gopkg-in-djherbis-times-v1
(package
(name "go-gopkg-in-djherbis-times-v1")
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index 34de6bdec9..96949f01e9 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -23,6 +23,7 @@
#:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages texinfo)
#:use-module (guix licenses)
#:use-module (guix packages)