aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-17 16:07:16 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-11-22 19:44:35 +0200
commit8c1ad1cecee9cb2ae31841f6f3e4c13352b86d06 (patch)
treee956c201a22e121ea341e1201295b1672b82ad62
parentc03e8cdc0c37e0a189557e7ade4b5ce656dbe17b (diff)
downloadguix-8c1ad1cecee9cb2ae31841f6f3e4c13352b86d06.tar
guix-8c1ad1cecee9cb2ae31841f6f3e4c13352b86d06.tar.gz
gnu: Add rust-sequoia-rfc2822-0.9.
* gnu/packages/crates-io.scm (rust-sequoia-rfc2822-0.9): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f4ebb7957b..f77d93d6e6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24393,6 +24393,45 @@ comparison.")
(base32
"18vhypw6zgccnrlm5ps1pwa0khz7ry927iznpr88b87cagr1v2iq"))))))
+(define-public rust-sequoia-rfc2822-0.9
+ (package
+ (name "rust-sequoia-rfc2822")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sequoia-rfc2822" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1aj34i6862718m162rqfv69fkmvdw063s6ws7hbp42n73gb08p5c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-failure" ,rust-failure-0.1)
+ ("rust-lalrpop" ,rust-lalrpop-0.17)
+ ("rust-lalrpop-util" ,rust-lalrpop-util-0.17))
+ #:cargo-development-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-quickcheck" ,rust-quickcheck-0.8)
+ ("rust-rand" ,rust-rand-0.6))))
+ (home-page "https://sequoia-pgp.org/")
+ (synopsis "RFC 2822 name-addr parser")
+ (description
+ "Currently, this crate only recognizes the RFC 2822 name-addr and
+addr-spec productions, i.e., things of the form:
+
+Name (Comment) <email@@example.org>
+
+and
+
+email@@example.org
+
+Although the above appear simple to parse, RFC 2822's whitespace and comment
+rules are rather complex. This crate implements the whole grammar." )
+ (license license:gpl3)))
+
(define-public rust-serde-1
(package
(name "rust-serde")