aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-07 16:52:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:18 +0100
commit89746f46b11c02e8d2c8826debc26f1e101bdc4e (patch)
tree740da15e1fd9cca799f836bc8cf5a60eb813cdd8
parente8605fab74d249eb4d649c0209201d2b0ba41067 (diff)
downloadguix-89746f46b11c02e8d2c8826debc26f1e101bdc4e.tar
guix-89746f46b11c02e8d2c8826debc26f1e101bdc4e.tar.gz
gnu: Add go-github-com-golang-glog.
* gnu/packages/golang-build.scm (go-github-com-golang-glog): New variable. Change-Id: I33dd7c2869590514b8351e389532c3a64273225d
-rw-r--r--gnu/packages/golang-build.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index a664c53c92..aee73f7aca 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
@@ -58,6 +59,31 @@
;;;
;;; Code:
+(define-public go-github-com-golang-glog
+ (package
+ (name "go-github-com-golang-glog")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/glog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a9ybpgp6grlpbhg2559sh54pxc9qfkhr4zvylw8qv1bny8c90q0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/golang/glog"))
+ (home-page "https://github.com/golang/glog")
+ (synopsis "Leveled execution logs for Golang")
+ (description
+ "This package implements logging analogous to C++ package
+@url{https://github.com/google/glog,glog} INFO/ERROR/V setup. It provides
+functions that have a name matched by regex:.")
+ (license license:asl2.0)))
+
(define-public go-github-com-golang-protobuf
(package
(name "go-github-com-golang-protobuf")