aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:49:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:31:07 +0300
commit88ce4ef9190a5ceb18b9ed50bbabb3328999a1a5 (patch)
treef3681be233b4a4f429045fee4f938dea959ff1e6
parentb5a9cb71b0c207a9c73f6a248d2f2e059b5aec08 (diff)
downloadguix-88ce4ef9190a5ceb18b9ed50bbabb3328999a1a5.tar
guix-88ce4ef9190a5ceb18b9ed50bbabb3328999a1a5.tar.gz
gnu: Add rust-proc-macro2-1.0.
* gnu/packages/rust-cbindgen.scm (rust-proc-macro2-1.0): New hidden variable.
-rw-r--r--gnu/packages/rust-cbindgen.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index a0bb7caee8..92364ad485 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -279,3 +279,24 @@ the platform that libc is compiled for.")
"This package can convert numbers into stack-allocated byte arrays.")
(properties '((hidden? . #t)))
(license (list license:expat license:asl2.0))))
+
+(define rust-proc-macro2-1.0
+ (package
+ (name "rust-proc-macro2")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "proc-macro2" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "09rgb5ab0jgw39kyad0lgqs4nb9yaf7mwcrgxqnsxbn4il54g7lw"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/alexcrichton/proc-macro2")
+ (synopsis "Stable implementation of the upcoming new `proc_macro` API")
+ (description "This package provides a stable implementation of the upcoming new
+`proc_macro` API. Comes with an option, off by default, to also reimplement itself
+in terms of the upstream unstable API.")
+ (properties '((hidden? . #t)))
+ (license (list license:expat license:asl2.0))))