aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-18 11:45:00 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:50 +0100
commit88b29ec5cfd16c7784e18d46c20351d4c3db69bd (patch)
tree1d238904e52fe65c3eba88506de074c6e48b4e5e
parentdaea7bc2234db20480bcd060fad9608ae843708b (diff)
downloadguix-88b29ec5cfd16c7784e18d46c20351d4c3db69bd.tar
guix-88b29ec5cfd16c7784e18d46c20351d4c3db69bd.tar.gz
gnu: ruby-tzinfo: Update to 2.0.6.
* gnu/packages/ruby.scm (ruby-tzinfo): Update to 2.0.6. [arguments,propagated-inputs]: Update style.
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 58276ef789..1f65d4a026 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7011,7 +7011,7 @@ utilities for Ruby.")
(define-public ruby-tzinfo
(package
(name "ruby-tzinfo")
- (version "2.0.4")
+ (version "2.0.6")
(source
(origin
(method git-fetch)
@@ -7022,31 +7022,29 @@ utilities for Ruby.")
(file-name (git-file-name name version))
(sha256
(base32
- "0jaq1givdaz5jxz47xngyj3j315n872rk97mnpm5njwm48wy45yh"))))
+ "1n1gzjqwwnx209h8d054miva0y7x17db2ahy7jav5r25ibhh7rgm"))))
(build-system ruby-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-safe-tests
- (lambda _
- (substitute* "test/test_utils.rb"
- (("def safe_test\\(options = \\{\\}\\)")
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-safe-tests
+ (lambda _
+ (substitute* "test/test_utils.rb"
+ (("def safe_test\\(options = \\{\\}\\)")
"def safe_test(options = {})
- skip('The Guix build environment has an unsafe load path')"))
- #t))
- (add-before 'check 'pre-check
- (lambda _
- (setenv "HOME" (getcwd))
- (substitute* "Gemfile"
- (("simplecov.*") "simplecov'\n"))
- #t))
- (replace 'check
- (lambda* (#:key tests? test-target #:allow-other-keys)
- (when tests?
- (invoke "bundler" "exec" "rake" test-target))
- #t)))))
+ skip('The Guix build environment has an unsafe load path')"))))
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (substitute* "Gemfile"
+ (("simplecov.*") "simplecov'\n"))))
+ (replace 'check
+ (lambda* (#:key tests? test-target #:allow-other-keys)
+ (when tests?
+ (invoke "bundler" "exec" "rake" test-target)))))))
(propagated-inputs
- `(("ruby-concurrent-ruby" ,ruby-concurrent)))
+ (list ruby-concurrent))
(native-inputs
(list ruby-simplecov))
(synopsis "Time zone library for Ruby")