aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-12 13:28:28 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-12 14:29:13 +0800
commit86690427b68202ba265b1d25ddecbcd2a2e1d0e6 (patch)
tree02d64b70bf6428c6ae9c370490ab394c42144a97
parent1a814b79ae54567b82359325530260c272fc9d4e (diff)
downloadguix-86690427b68202ba265b1d25ddecbcd2a2e1d0e6.tar
guix-86690427b68202ba265b1d25ddecbcd2a2e1d0e6.tar.gz
gnu: coq-equations: Update style.
* gnu/packages/coq.scm (coq-equations)[arguments]: Use G-expression. Change-Id: Ib34ec1d543775f96777dfe31990b6526f589bee6
-rw-r--r--gnu/packages/coq.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index e3212a88ef..31d1e8d51d 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -582,18 +582,18 @@ uses Ltac to synthesize the substitution operation.")
(native-inputs
(list ocaml coq camlp5))
(arguments
- `(#:test-target "test-suite"
- #:make-flags (list (string-append "COQLIBINSTALL="
- (assoc-ref %outputs "out")
- "/lib/coq/user-contrib")
- (string-append "COQPLUGININSTALL="
- (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib/"))
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "sh" "./configure.sh"))))))
+ (list #:test-target "test-suite"
+ #:make-flags #~(list (string-append "COQLIBINSTALL="
+ #$output
+ "/lib/coq/user-contrib")
+ (string-append "COQPLUGININSTALL="
+ #$output
+ "/lib/ocaml/site-lib/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "sh" "./configure.sh"))))))
(home-page "https://mattam82.github.io/Coq-Equations/")
(synopsis "Function definition plugin for Coq")
(description "Equations provides a notation for writing programs