aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-24 21:21:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:23 +0100
commit863197b9e687cb889d9a03101b509f8d782ec21c (patch)
tree56fcbff8889e0c43da94ab113e8583391a8c3f76
parentc8dc5b1e1ef44da777a28d9da94476829337284c (diff)
downloadguix-863197b9e687cb889d9a03101b509f8d782ec21c.tar
guix-863197b9e687cb889d9a03101b509f8d782ec21c.tar.gz
gnu: Add go-atomicgo-dev-cursor.
* gnu/packages/golang-xyz.scm (go-atomicgo-dev-cursor): New variable. Change-Id: I7d742bf6056b3169999157af55cc1c002e6aceb9
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0f7d462816..4bdcc05c47 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -85,6 +85,32 @@
;;; Libraries:
;;;
+(define-public go-atomicgo-dev-cursor
+ (package
+ (name "go-atomicgo-dev-cursor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomicgo/cursor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ds85nyd3dnjr961x9g5kflx1qdb92vn7n6wc4jbk0fjjzbrnh5s"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "atomicgo.dev/cursor"))
+ (home-page "https://atomicgo.dev/cursor")
+ (synopsis "Moving terminal cursor in Golang")
+ (description
+ "Package cursor contains cross-platform methods to move the terminal cursor in
+different directions. This package can be used to create interactive CLI tools
+and games, live charts, algorithm visualizations and other updatable output of
+any kind.")
+ (license license:expat)))
+
(define-public go-bazil-org-fuse
(package
(name "go-bazil-org-fuse")