aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-11-06 08:32:40 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-08 15:28:42 +0800
commit812512413ae521faa184f783d69bbfa4a9f492ac (patch)
tree29e04617395e20b600ebb6644c0e2d11677a8a19
parent28e2e185aeecaf01f6b4591048f26dfc690a6eb9 (diff)
downloadguix-812512413ae521faa184f783d69bbfa4a9f492ac.tar
guix-812512413ae521faa184f783d69bbfa4a9f492ac.tar.gz
gnu: Add hyprutils.
* gnu/packages/wm.scm (hyprutils): New variable. Modified-by: Hilton Chain <hako@ultrarare.space> Signed-off-by: Hilton Chain <hako@ultrarare.space> Change-Id: Ife120a7c2d66b7189a3116f8dbcb53be8dafd58e
-rw-r--r--gnu/packages/cpp.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index eacc6e46ab..fdace00ef8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -113,6 +113,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
;; Using autoload to avoid a cycle.
@@ -663,6 +664,29 @@ operating on batches.")
library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
(license license:asl2.0)))
+(define-public hyprutils
+ (package
+ (name "hyprutils")
+ (version "0.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprutils")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01dh24rf62gb6xm32f7mfv6wx0dxprr1q9y73hvv7xanrjyia2zn"))))
+ (build-system cmake-build-system)
+ (native-inputs (list gcc-13 pkg-config))
+ (inputs (list pixman))
+ (home-page "https://github.com/hyprwm/hyprutils")
+ (synopsis "C++ library for utilities used across Hyprland ecosystem")
+ (description
+ "This package provides a C++ library for utilities used across Hyprland
+ecosystem.")
+ (license license:bsd-3)))
+
(define-public xsimd-benchmark
(package
(inherit xsimd)