aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-20 14:26:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-20 17:02:34 +0200
commit8084e3bdb3c22b735d3e8df282a3bcb0a7ca6a59 (patch)
treef68bde53297936d4573ec6962d26c0000ffd7e2e
parent9ed635cd9aba00991aae501f5ffa42a8a93d9e1d (diff)
downloadguix-8084e3bdb3c22b735d3e8df282a3bcb0a7ca6a59.tar
guix-8084e3bdb3c22b735d3e8df282a3bcb0a7ca6a59.tar.gz
gnu: python-pyvcf: Update to 0.6.8-0.476169c.
* gnu/packages/bioinformatics.scm (python-pyvcf): Update to 0.6.8-0.476169c.
-rw-r--r--gnu/packages/bioinformatics.scm72
1 files changed, 37 insertions, 35 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d35e86cd3e..f54ac6ffab 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15541,47 +15541,49 @@ for the analysis and visualization of raw nanopore signal.")
(license license:mpl2.0)))
(define-public python-pyvcf
- (package
- (name "python-pyvcf")
- (version "0.6.8")
- ;; Use git, because the PyPI tarballs lack test data.
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
+ (let ((commit "476169cd457ba0caa6b998b301a4d91e975251d9")
+ (revision "0"))
+ (package
+ (name "python-pyvcf")
+ (version (git-version "0.6.8" revision commit))
+ ;; Use git, because the PyPI tarballs lack test data.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
(url "https://github.com/jamescasbon/PyVCF.git")
;; Latest release is not tagged.
- (commit "bfcedb9bad1a14074ac4526ffdb610611e073810")))
- (file-name (git-file-name name version))
- (sha256
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
(base32
- "0c7lsssns3zp8fh2ibllzzra003srg9vbxqzmq6654akbzdb7lrf"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-sample-script
- (lambda _
- ;; Add Python 3 compatibility to this sample script.
- (substitute* "scripts/vcf_sample_filter.py"
- (("print (.*)\n" _ arg)
- (string-append "print(" arg ")\n")))))
- (add-after 'install 'remove-installed-tests
- ;; Do not install test files.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (delete-file-recursively (string-append
+ "0qf9lwj7r2hjjp4bd4vc7nayrhblfm4qcqs4dbd43a6p4bj2jv5p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-sample-script
+ (lambda _
+ ;; Add Python 3 compatibility to this sample script.
+ (substitute* "scripts/vcf_sample_filter.py"
+ (("print (.*)\n" _ arg)
+ (string-append "print(" arg ")\n")))))
+ (add-after 'install 'remove-installed-tests
+ ;; Do not install test files.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (delete-file-recursively (string-append
(site-packages inputs outputs)
"/vcf/test")))))))
- (native-inputs
- ;; Older setuptools is needed for use_2to3.
- (list python-cython python-setuptools-for-tensorflow))
- (propagated-inputs
- (list python-pysam python-rpy2))
- (home-page "https://github.com/jamescasbon/PyVCF")
- (synopsis "Variant Call Format parser for Python")
- (description "This package provides a @acronym{VCF,Variant Call Format}
+ (native-inputs
+ ;; Older setuptools is needed for use_2to3.
+ (list python-cython python-setuptools-for-tensorflow))
+ (propagated-inputs
+ (list python-pysam python-rpy2))
+ (home-page "https://github.com/jamescasbon/PyVCF")
+ (synopsis "Variant Call Format parser for Python")
+ (description "This package provides a @acronym{VCF,Variant Call Format}
parser for Python.")
- (license license:expat)))
+ (license license:expat))))
(define-public nanosv
(package