aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-02 10:50:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:46:47 +0300
commit7dd38422f744d25ce18e434963e9399e5831bf4a (patch)
tree706f1b9724ede640520bfa261e2390fc1b063bab
parentb523524160f3e3ee8e5a2f638eae3ef1649f571d (diff)
downloadguix-7dd38422f744d25ce18e434963e9399e5831bf4a.tar
guix-7dd38422f744d25ce18e434963e9399e5831bf4a.tar.gz
gnu: rust-funty-1: Downgrade to 1.1.0.
Later versions of this crate were yanked by upstream. * gnu/packages/crates-io.scm (rust-funty-1): Downgrade to 1.1.0. (rust-funty-1.1): Remove variable. (rust-bitvec-0.20, rust-bitvec-0.19)[cargo-inputs]: Replace rust-funty-1.1 with 1. Change-Id: If9c33219ca89e3036d6a58fe47865d10293e7410
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 5 insertions, 32 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b67de2530a..3e16e021e4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8301,7 +8301,7 @@ streams in big-endian and little-endian formats.")
'("--release" "--"
"--skip=slice::tests::get_set")
#:cargo-inputs
- (("rust-funty" ,rust-funty-1.1)
+ (("rust-funty" ,rust-funty-1)
("rust-radium" ,rust-radium-0.6)
("rust-serde" ,rust-serde-1)
("rust-tap" ,rust-tap-1)
@@ -8328,7 +8328,7 @@ streams in big-endian and little-endian formats.")
(base32 "0cvb24nanb50vq61d3ac3pz7rxjcy0w6lr3nb56kcg1nyc73vyam"))))
(arguments
`(#:cargo-inputs
- (("rust-funty" ,rust-funty-1.1)
+ (("rust-funty" ,rust-funty-1)
("rust-radium" ,rust-radium-0.5)
("rust-serde" ,rust-serde-1)
("rust-tap" ,rust-tap-1)
@@ -27894,43 +27894,16 @@ references by lifting access permissions into the trait system.")
(define-public rust-funty-1
(package
- (name "rust-funty")
- (version "1.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "funty" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07lb1f8yih3g694id3n90anlgxf8m6p98bllsnn6dmb5rfwsniqq"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-development-inputs
- (("rust-static-assertions" ,rust-static-assertions-1))))
- (home-page "https://github.com/myrrlyn/funty")
- (synopsis "Trait generalization over the primitive types")
- (description
- "Prior to 1.0, Rust had traits for the numeric primitive types to permit
-code to generalize over which specific type it accepted. This was never
-stabilized, and eventually removed. This library reïnstates these traits.")
- (license license:expat)))
-
-(define-public rust-funty-1.1
- (package
- (inherit rust-funty-1)
+ (inherit rust-funty-2)
(name "rust-funty")
(version "1.1.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "funty" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "19wx3p3jmv863y0mjb56sr4qf1kvqhl3fsyslkd92zli0p8lrlzy"))))
+ (base32 "19wx3p3jmv863y0mjb56sr4qf1kvqhl3fsyslkd92zli0p8lrlzy"))))
(arguments
`(#:cargo-development-inputs
(("rust-static-assertions" ,rust-static-assertions-1))))))