aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-04-08 16:59:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-11 16:11:45 +0200
commit7cd1dd3e105341df7c72d67f45df6a872be865ba (patch)
treeb39acfb2450f4d6c11b031a4e35ecc669c7cf255
parent88d0b086a98638f23982addc68ca1142a056bd6e (diff)
downloadguix-7cd1dd3e105341df7c72d67f45df6a872be865ba.tar
guix-7cd1dd3e105341df7c72d67f45df6a872be865ba.tar.gz
gnu: Add r-paralleldist.
* gnu/packages/cran.scm (r-paralleldist): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index be77a57f28..8a7d98cf30 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1074,6 +1074,31 @@ consistent fashion. It seeks to combine functionality from lower level
functions which can speed up workflow.")
(license license:gpl2)))
+(define-public r-paralleldist
+ (package
+ (name "r-paralleldist")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "parallelDist" version))
+ (sha256
+ (base32 "01ly4hxwa64a0ya5gla8rvv72s9mcknsfznivjkh937pbjwb7iih"))))
+ (properties `((upstream-name . "parallelDist")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcpparmadillo r-rcppparallel))
+ (home-page "https://github.com/alexeckert/parallelDist")
+ (synopsis "Parallel Distance Matrix Computation using multiple threads")
+ (description
+ "This package provides a fast parallelized alternative to R's native
+@code{dist} function to calculate distance matrices for continuous, binary,
+and multi-dimensional input matrices, which supports a broad variety of
+predefined distance functions from other R packages, as well as user- defined
+functions written in C++. For ease of use, the @code{parDist} function
+extends the signature of the @code{dist} function and uses the same parameter
+naming conventions as distance methods of existing R packages.")
+ (license license:gpl2+)))
+
(define-public r-pheatmap
(package
(name "r-pheatmap")