aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-21 03:18:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-21 03:21:35 +0300
commit7cad70566322262f6acdbbb965e867e34010eb55 (patch)
treec08110b6cc8d309baa37f9c2a37cf9dbdbf9806a
parent32de7edf029878675ad3b257ae241a3d568d7efc (diff)
downloadguix-7cad70566322262f6acdbbb965e867e34010eb55.tar
guix-7cad70566322262f6acdbbb965e867e34010eb55.tar.gz
gnu: texlivetexmf: Fix building on riscv64-linux.
* gnu/packages/texlive.scm (texlivetexmf)[arguments]: Adjust the custom 'texlive-texmf phase to skip targets dependant on luajit when building for riscv64-linux.
-rw-r--r--gnu/packages/texlive.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 0204a256ef..1a50eb454f 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
@@ -313,8 +313,9 @@ This package contains the binaries.")
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))
- ;; LuaJIT is not ported to powerpc64* yet.
- (if ,(target-ppc64le?)
+ ;; LuaJIT is not ported to some systems yet.
+ (if ,(or (target-ppc64le?)
+ (target-riscv64?))
(substitute* fmtutilcnf
(("^(luajittex|luajithbtex|mfluajit)" m)
(string-append "#! " m))))