aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-10 19:48:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-10 19:55:29 +0200
commit7ba2a1af5cc5f3e914fb3eb4b562e4676a659880 (patch)
tree5d1365f7a5934316ff38e21ee167f23b5340fe93
parent6b86af5a09a08884b132acd3f8fde1e75810b216 (diff)
downloadguix-7ba2a1af5cc5f3e914fb3eb4b562e4676a659880.tar
guix-7ba2a1af5cc5f3e914fb3eb4b562e4676a659880.tar.gz
gnu: wine: Limit supported architectures to ones that can build our wine.
* gnu/packages/wine.scm (wine)[supported systems]: New field, limit to architectures which can build for their selected '#:system'.
-rw-r--r--gnu/packages/wine.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index da7620cd3d..de1fa7aa2a 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -155,6 +155,9 @@ simulating internal Windows logic like a virtual machine or emulator, Wine
translates Windows API calls into POSIX calls on-the-fly, eliminating the
performance and memory penalties of other methods and allowing you to cleanly
integrate Windows applications into your desktop.")
+ ;; Any platform should be able to build wine, but based on '#:system' these
+ ;; are thr ones we currently support.
+ (supported-systems '("i686-linux" "x86_64-linux" "armhf-linux"))
(license license:lgpl2.1+)
;; It really only supports IA32, but building on x86_64 will have the same