aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:11:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:17 +0200
commit7b6249d285cf4ba63564b1309fa612e376f7a9e5 (patch)
tree5ac4efe986d4790c6c3a879bf531aa4887d8d4d9
parent023332f69eb77d1f3769ef3fef78a864afe7fada (diff)
downloadguix-7b6249d285cf4ba63564b1309fa612e376f7a9e5.tar
guix-7b6249d285cf4ba63564b1309fa612e376f7a9e5.tar.gz
gnu: Add texlive-chemcompounds.
* gnu/packages/tex.scm (texlive-chemcompounds): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 451b01fe4e..c1b55e6329 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2254,6 +2254,28 @@ in the font are designed to look more like those in chemistry text-books than
do Knuth's originals.")
(license license:public-domain)))
+(define-public texlive-chemcompounds
+ (package
+ (name "texlive-chemcompounds")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/chemcompounds/"
+ "source/latex/chemcompounds/"
+ "tex/latex/chemcompounds/")
+ (base32
+ "0bk625vdd6i1dc2569ypcq27hin1yggvadf18463qb6xhyndplvf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/chemcompounds")
+ (synopsis "Simple consecutive numbering of chemical compounds")
+ (description
+ "The chemcompounds package allows for a simple consecutive numbering of
+chemical compounds. Optionally, it is possible to supply a custom name for
+each compound. The package differs from the @code{chemcono} package by not
+generating an odd-looking list of compounds inside the text.")
+ (license license:lppl)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")