aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 12:48:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:55 +0200
commit7ace1bbbdfe58a8a1ece209f9cf597694cf6518c (patch)
treec75b7625cea8fbe051c325c228d17520641a68e9
parent427a317fff25182091a9ea02a18d830aec2d14c0 (diff)
downloadguix-7ace1bbbdfe58a8a1ece209f9cf597694cf6518c.tar
guix-7ace1bbbdfe58a8a1ece209f9cf597694cf6518c.tar.gz
gnu: rust-libpijul-0.12: Move to (gnu packages crates-vcs).
* gnu/packages/crates-io.scm (rust-libpijul-0.12): Move from here ... * gnu/packages/crates-vcs.scm: ... to here. Change-Id: Id294ae669ca2d837ceb953ced02264366b828e9e
-rw-r--r--gnu/packages/crates-io.scm63
-rw-r--r--gnu/packages/crates-vcs.scm65
2 files changed, 65 insertions, 63 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3e166b18b4..dd6bcd33a7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39059,69 +39059,6 @@ advertised and discovered using this mechanism.")
(license (list license:asl2.0
license:expat))))
-;; Keep this package for future packaging of pijul.
-(define-public rust-libpijul-0.12
- (package
- (name "rust-libpijul")
- (version "0.12.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "libpijul" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "18d9n8xaq5ncq3375f0xrr96l8si1frczgzdlrz3fl1jby8vbl6f"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t ; TODO: Fix build
- #:tests? #f ; backend::file_header::test_fileheader_alignment fails
- #:cargo-inputs
- (("rust-base64" ,rust-base64-0.10)
- ("rust-bincode" ,rust-bincode-1)
- ("rust-bitflags" ,rust-bitflags-1)
- ("rust-bs58" ,rust-bs58-0.2)
- ("rust-byteorder" ,rust-byteorder-1)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-diffs" ,rust-diffs-0.3)
- ("rust-failure" ,rust-failure-0.1)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-hex" ,rust-hex-0.3)
- ("rust-ignore" ,rust-ignore-0.4)
- ("rust-log" ,rust-log-0.4)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.6)
- ("rust-sanakirja" ,rust-sanakirja-0.10)
- ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-0.9)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-tempdir" ,rust-tempdir-0.3)
- ("rust-toml" ,rust-toml-0.4))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list clang nettle openssl))
- (home-page "https://pijul.org/")
- (synopsis "Library component of the pijul version control system")
- (description
- "This crate contains the core API to access Pijul repositories.
-
-The key object is a @code{Repository}, on which @code{Txn} (immutable
-transactions) and @code{MutTxn} (mutable transactions) can be started, to
-perform a variety of operations.
-
-Another important object is a @code{Patch}, which encodes two different pieces
-of information:
-
-@itemize
-@item Information about deleted and inserted lines between two versions of a
-file.
-@item Information about file moves, additions and deletions.
-@end itemize")
- (license license:gpl2+)))
-
(define-public rust-libpulse-binding-2
(package
(name "rust-libpulse-binding")
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index f0cba15b31..3b509468aa 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -32,7 +32,10 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages nettle)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages sequoia)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control))
@@ -3003,3 +3006,65 @@ state. Used by Gitoxide a pure Rust implementation of Git.")
from a git-tree. It's part of Gitoxide, a pure Rust implementation of Git.")
(license (list license:expat license:asl2.0))))
+;; Keep this package for future packaging of pijul.
+(define-public rust-libpijul-0.12
+ (package
+ (name "rust-libpijul")
+ (version "0.12.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "libpijul" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18d9n8xaq5ncq3375f0xrr96l8si1frczgzdlrz3fl1jby8vbl6f"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; TODO: Fix build
+ #:tests? #f ; backend::file_header::test_fileheader_alignment fails
+ #:cargo-inputs
+ (("rust-base64" ,rust-base64-0.10)
+ ("rust-bincode" ,rust-bincode-1)
+ ("rust-bitflags" ,rust-bitflags-1)
+ ("rust-bs58" ,rust-bs58-0.2)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-diffs" ,rust-diffs-0.3)
+ ("rust-failure" ,rust-failure-0.1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-hex" ,rust-hex-0.3)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-rand" ,rust-rand-0.6)
+ ("rust-sanakirja" ,rust-sanakirja-0.10)
+ ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-0.9)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tempdir" ,rust-tempdir-0.3)
+ ("rust-toml" ,rust-toml-0.4))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list clang nettle openssl))
+ (home-page "https://pijul.org/")
+ (synopsis "Library component of the pijul version control system")
+ (description
+ "This crate contains the core API to access Pijul repositories.
+
+The key object is a @code{Repository}, on which @code{Txn} (immutable
+transactions) and @code{MutTxn} (mutable transactions) can be started, to
+perform a variety of operations.
+
+Another important object is a @code{Patch}, which encodes two different pieces
+of information:
+
+@itemize
+@item Information about deleted and inserted lines between two versions of a
+file.
+@item Information about file moves, additions and deletions.
+@end itemize")
+ (license license:gpl2+)))