aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:36:06 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:36:23 +0100
commit7a6f5b05028af5a2796bcf3205d5ac63ddeb2c0e (patch)
treee8d0d74bf4f408d495b7e939efff63765977f5fd
parent39fab0cf8c48cf0804d87a5d72bd80426b80eaf7 (diff)
downloadguix-7a6f5b05028af5a2796bcf3205d5ac63ddeb2c0e.tar
guix-7a6f5b05028af5a2796bcf3205d5ac63ddeb2c0e.tar.gz
gnu: go-github-com-arceliar-ironwood: Enable tests.
* gnu/packages/golang.scm (go-github-com-arceliar-ironwood): Enable most of the tests. [arguments]: <#:phases>: Add 'remove-examples and use custom 'check phase. [propagated-inputs]: Add go-github-com-bits-and-blooms-bitset and go-github-com-bits-and-blooms-bloom-v3. Change-Id: I3319e291927e8aa53ce90d00d2cbf6a9df684568
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 82575caa94..11d806c3de 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8176,14 +8176,26 @@ dependencies and a simple API.")
"06ay82gqm3k649m7x0r3a3crnqv9x0yxhyqfabrf1b7inki35mfs"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/Arceliar/ironwood"
- #:tests? #f
- #:phases
- #~(modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
+ (list
+ #:import-path "github.com/Arceliar/ironwood"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/cmd/ironwood-example"))))
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
- (list go-golang-org-x-crypto go-github-com-arceliar-phony))
+ (list go-github-com-arceliar-phony
+ go-github-com-bits-and-blooms-bitset
+ go-github-com-bits-and-blooms-bloom-v3
+ go-golang-org-x-crypto))
(home-page "https://github.com/Arceliar/ironwood")
(synopsis "Experimental network routing library")
(description