aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-16 10:17:20 -0500
committerjgart <jgart@dismail.de>2024-07-16 10:17:20 -0500
commit79b1f401768631234022b3344e7726e60cb3e73c (patch)
treecb79ddde9cc3be1cb6ac7e7b43df0283b0e0661d
parent237cc5d149422ce88e5007e14d7d784129ac9ff4 (diff)
downloadguix-79b1f401768631234022b3344e7726e60cb3e73c.tar
guix-79b1f401768631234022b3344e7726e60cb3e73c.tar.gz
gnu: Add python-geojson-for-pyowm.
* gnu/packages/python-xyz.scm (python-geojson-for-pyowm): New variable. Change-Id: I529429ef7ee600788df07d7f5fd41cec7ab29ba9
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fec11134e9..2a51320d59 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16017,6 +16017,21 @@ Python code formatter \"black\".")
structures.")
(license license:bsd-3)))
+;; pyowm only accepts a version less than version 3.
+(define-public python-geojson-for-pyowm
+ (package
+ (inherit python-geojson)
+ (version "2.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geojson" version))
+ (sha256
+ (base32 "12k5bzqskvq3gqzkryarhdjl0df47y5k9cf8r3clasi2wjnbfjvf"))))
+ (arguments
+ ;; https://github.com/jazzband/geojson/issues/175
+ (list #:tests? #f))))
+
(define-public wfetch
(let ((commit "e1cfa37814aebc9eb56ce994ebe877b6a6f9a715")
(revision "1"))